Welcome to docs.opsview.com

Differences

This shows you the differences between two versions of the page.

opsview4.6:checkupdates [2014/09/09 12:19] (current)
Line 1: Line 1:
 +====== Opsview Check Updates ======
 +The Opsview check update plugin, called //check_opsview_update//, works by sending your version information to our central servers (at http://downloads.opsview.org, under the /updates path) which will then reply with the version number most appropriate to your Opsview system.
 +You can edit the System Preferences' Updates tab to control the parameter //Include Major Updates//.
 +
 +The response from our central server will depend on whether you have the Enterprise edition (the 2nd digit in the version is even) or the Community edition (the 2nd digit is odd) version of Opsview. The basic rules are:
 +  * Community releases always have major update set to yes
 +  * If there is a higher major release for your edition **and** the major update is set, alert
 +  * If there is a higher minor release (3rd digit in the version number), alert
 +  * You do not get alerted about releases in other editions
 +
 +The table below demonstrates what will the response be and whether the plugin will raise an alert.
 +
 +^^Your current version^^Major Updates?^^Latest releases^^Response^^Alert^^
 +|| 3.3.0 (Community) || Yes || 3.3.0 || 3.3.0 || No  ||
 +|| 3.3.0 || Yes || 3.3.1 || 3.3.1 || Yes ||
 +|| 3.3.0 || Yes || 3.3.0, 3.4.0 || 3.3.0 || No  ||
 +|| 3.3.0 || Yes || 3.3.1, 3.4.0 || 3.3.1 || Yes ||
 +|| 3.3.0 || Yes || 3.3.0, 3.4.0, 3.5.0 || 3.5.0 || Yes ||
 +|| 3.3.0 || Yes || 3.3.1, 3.4.0, 3.5.0 || 3.5.0 || Yes ||
 +|| 3.4.0 (Enterprise) || Yes || 3.4.0 || 3.4.0 || No  ||
 +|| 3.4.0 || Yes || 3.4.1 || 3.4.1 || Yes ||
 +|| 3.4.0 || Yes || 3.4.0, 3.5.0 || 3.4.0 || No  ||
 +|| 3.4.0 || Yes || 3.4.1, 3.5.0 || 3.4.1 || Yes ||
 +|| 3.4.0 || Yes || 3.4.0, 3.5.0, 3.6.0 || 3.6.0 || Yes ||
 +|| 3.4.0 || Yes || 3.4.1, 3.5.0, 3.6.0 || 3.6.0 || Yes ||
 +|| 3.4.0 || No  || 3.4.0               || 3.4.0 || No  ||
 +|| 3.4.0 || No  || 3.4.1               || 3.4.1 || Yes ||
 +|| 3.4.0 || No  || 3.4.0, 3.5.0        || 3.4.0 || No  ||
 +|| 3.4.0 || No  || 3.4.1, 3.5.0        || 3.4.1 || Yes ||
 +|| 3.4.0 || No  || 3.4.0, 3.5.0, 3.6.0 || 3.4.0 || No  ||
 +|| 3.4.0 || No  || 3.4.1, 3.5.0, 3.6.0 || 3.4.1 || Yes ||
 +
 +The plugin can make use of an HTTP proxy if required via the --proxy flag in order to access the web.
Navigation
Print/export
Toolbox